Weird Feedback Issue

aaronlowther1993

TDPRI Member
Joined
Sep 4, 2016
Posts
75
Age
29
Location
Claremore, OK
I'm working over a Showman Reverb TFL 5000D for a buddy, and it's got an odd issue. Whenever a guitar is plugged into the amp, it will feedback at full volume.

Just plugging a cable in and tap the end? No feedback. The volume and tone controls have no affect on the feedback. I had the unit on a load with a sine wave generator and the scope on it, and couldn't reproduce it into the load. Even when plugging an electric guitar into the amp with it on a load, it won't feedback. At least not in a way that I can find on the scope.

I've tested with multiple cables, speakers, and guitars, and isolated it down to the amp. I pulled the negative feedback from the circuit and it still occurs. Working from the back, the issue doesn't occur if the phase inverter is pulled, but that's as far as I've gotten.

Any advice?
 

radiocaster

Doctor of Teleocity
Joined
Aug 18, 2015
Posts
10,041
Location
europe
I don't know if this is the problem, but have you checked the cathode resistors? Remove tubes first to avoid false readings.
 

aaronlowther1993

TDPRI Member
Joined
Sep 4, 2016
Posts
75
Age
29
Location
Claremore, OK
Normal or vibrato input?
Normal is controlled by V1
Vibrato V2.
Check which one and look around those input sockets for bad grounding.

Is it affected by the relevant volume control?
Normal input
Sockets look good, but will go ahead and run some freeze spray across them.

Volume control doesn't do anything.
 

Bendyha

Friend of Leo's
Silver Supporter
Joined
Mar 26, 2014
Posts
3,415
Location
Northern Germany
Possibly, the ground reference for the volume has been interrupted. The tone also does nothing though, you say, could it to have lost the ground reference?
 

Burning Fingers

Tele-Meister
Silver Supporter
Joined
Mar 6, 2019
Posts
193
Age
68
Location
Australia
Try removing the reverb driver tube (V3) and if that doesn't stop the feedback remove the vibrato tube ( V2). If removing either of those 2 tubes stops the squeal then it will narrow down the fault area.
What happens if the guitar volume is turned down to zero ?
I have met a few old amps where the reverb circuit caused feedback that could not be silenced with the volume control...sometimes it was a bad tube and other times it was a reverb pot or the wrong reverb transformer.
 




Top