1. Win a Broadcaster or one of 3 Teles! The annual Supporting Member Giveaway is on. To enter Click Here. To see all the prizes and full details Click Here. To view the thread about the giveaway Click Here.

VOX VT20 making no sound

Discussion in 'Amp Central Station' started by funkymonkmike11, Jun 21, 2020.

  1. funkymonkmike11

    funkymonkmike11 TDPRI Member

    Age:
    23
    Posts:
    4
    Joined:
    Jun 21, 2020
    Location:
    birmingham
    Hey guys,

    I showed up to a rehearsal and when I tried plugging in, my amp was not making any sound. I've had my VOX VT20 amp for over 3 years now, and this has never happened to me before. The amp is on, but nothing is coming through. Do I need to replace a fuse, or could it be something different? I don't have any experience with amp repairs, so any advice would be highly appreciated.

    Thanks in advance!

    Mike
     
  2. PlainAllman

    PlainAllman Tele-Afflicted

    Age:
    45
    Posts:
    1,434
    Joined:
    Feb 12, 2019
    Location:
    Van Zandt Co, Texas
    Could be the speaker is disconnected. I’m no amp tech but that seems like a good place to start.
     
  3. john_cribbin

    john_cribbin Tele-Afflicted

    Posts:
    1,515
    Joined:
    Nov 26, 2014
    Location:
    London
    Try it with headphones. The socket is known to fail.
     
    PlainAllman likes this.
  4. funkymonkmike11

    funkymonkmike11 TDPRI Member

    Age:
    23
    Posts:
    4
    Joined:
    Jun 21, 2020
    Location:
    birmingham
    Thanks, I'll take a look at it. I did not have a screwdriver with me, so I could not open the amp and take a look, but thanks anyways. I was just wondering if this happened to someone else before
     
  5. PlainAllman

    PlainAllman Tele-Afflicted

    Age:
    45
    Posts:
    1,434
    Joined:
    Feb 12, 2019
    Location:
    Van Zandt Co, Texas
    I’m sure it’s happened to someone else before but the cause may not always be the same. I’ve got the VT40 and its a sweet little amp. I haven’t had any issues with it yet. I did just get it back from being on loan to my BIL for a few months though so hopefully it’s still good. :confused::lol:
     
  6. funkymonkmike11

    funkymonkmike11 TDPRI Member

    Age:
    23
    Posts:
    4
    Joined:
    Jun 21, 2020
    Location:
    birmingham
    thanks John, didn't think of it when I was in the lockup, but will do tomorrow.
     
  7. funkymonkmike11

    funkymonkmike11 TDPRI Member

    Age:
    23
    Posts:
    4
    Joined:
    Jun 21, 2020
    Location:
    birmingham
    These amps are great in my opinion. Versatile, loud, great sound, I've played many shows with it over the years and never had any issues until now :)
     
  8. esseff

    esseff Tele-Afflicted

    Age:
    65
    Posts:
    1,538
    Joined:
    Mar 25, 2014
    Location:
    East Midlands, UK
    Don't know if it's the same with yours but I once had a VT15 that I bought cheaply as broken on eBay. The problem turned out to be a cracked headphone socket circuit board, which I replaced with no further issues. A design defect, the mini jack is vertically mounted and any sideways leverage flexes the PCB below, which ultimately causes failure. Using a right-angled headphone jack is the solution.
     
    Last edited: Jun 22, 2020
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.