Updated my pedalboard; ready to start gigging again!

Discussion in 'The Stomp Box' started by Bob Arbogast, Jun 1, 2020.

  1. Bob Arbogast

    Bob Arbogast Tele-Afflicted Silver Supporter

    Posts:
    1,676
    Joined:
    Mar 16, 2003
    Location:
    Lowell, Michigan USA
    I've been on a simplicity kick during these COVID days. Here's what my pedalboard is looking like. I'm ready for gigs to start again.

    [​IMG]

    Guitars will be a T-style partscaster and an Epiphone Casino.

    I can't wait!
     
    4pickupguy, Slip Kid, rhino and 8 others like this.
  2. cyclopean

    cyclopean Friend of Leo's

    Posts:
    4,576
    Joined:
    Aug 14, 2009
    Location:
    innsmouth, MA
    with just two pedals i probably wouldn't have bothered.
     
  3. Bob Arbogast

    Bob Arbogast Tele-Afflicted Silver Supporter

    Posts:
    1,676
    Joined:
    Mar 16, 2003
    Location:
    Lowell, Michigan USA
    Well, there were other pedals on the board. They're all gone now but for one, and it's in a box.

    I do have a simpler set-up: a second Z-Drive and a clip-on tuner!
     
    Seasicksailor and 68Telebass like this.
  4. naveed211

    naveed211 Tele-Afflicted

    Posts:
    1,031
    Joined:
    May 16, 2009
    Location:
    wisconsin
    What's your amp? Maybe something with reverb and tremolo? Gotta have a little splashy splashy or wobbly wobbly...I do, at least.

    Always wanted to a try a Z-Drive.
     
    FenderGuy53 and Seasicksailor like this.
  5. studio1087

    studio1087 Telefied Silver Supporter

    Posts:
    24,689
    Joined:
    May 10, 2003
    Location:
    Near Milwaukee
    I think it’s great. Z-Drive.....nice!
     
  6. 68Telebass

    68Telebass Tele-Afflicted

    Posts:
    1,519
    Joined:
    Aug 2, 2014
    Location:
    Northern Arizona
    love the board!!! I must look at the Z-Drive- seems quite a nice two channel pedal...

    let us know how it goes!! And yes, what amp?
     
  7. Bob Arbogast

    Bob Arbogast Tele-Afflicted Silver Supporter

    Posts:
    1,676
    Joined:
    Mar 16, 2003
    Location:
    Lowell, Michigan USA
    Mostly I play through a 2x10 Deluxe Reverb clone (Celestion Greenback 10 + Eminence/Allessandro GA10-SC64).
     
  8. 985plowboy

    985plowboy Friend of Leo's

    Posts:
    2,896
    Joined:
    Feb 5, 2012
    Location:
    South Louisiana
    Love it.
    I use a tuner, a drive pedal and delay. Amp has reverb and trem.
    All I need.
    Sometimes more than I need.
     
  9. Bob Arbogast

    Bob Arbogast Tele-Afflicted Silver Supporter

    Posts:
    1,676
    Joined:
    Mar 16, 2003
    Location:
    Lowell, Michigan USA
    I've never really cottoned to delay. Whenever I use it, it's either unnoticeable or too much. I guess I'm just an old dog.
     
  10. 985plowboy

    985plowboy Friend of Leo's

    Posts:
    2,896
    Joined:
    Feb 5, 2012
    Location:
    South Louisiana
    I couldn’t get along with delay for years. I was using way too much and didn’t know it.
    I have a MXR CC set a little longer than slap back and only a couple repeats. Half the volume of the initial note.
    It helps fill and sustain on certain songs.
    But, And this is another thing that I had to learn, it does not work on every song.
    Sometimes you have to turn it off.
     
  11. TommyBaltimore

    TommyBaltimore TDPRI Member

    Age:
    49
    Posts:
    67
    Joined:
    May 28, 2020
    Location:
    Inthecity
    A perfect miniboard Monday post. Put a battery in it and use a clip on tuner. I wish I could be as minimalistic.
     
  12. FenderGuy53

    FenderGuy53 Poster Extraordinaire

    Posts:
    6,945
    Joined:
    May 14, 2008
    Location:
    Marion, NC
    Hmmm...
     
    Last edited: Jun 2, 2020
  13. Bob Arbogast

    Bob Arbogast Tele-Afflicted Silver Supporter

    Posts:
    1,676
    Joined:
    Mar 16, 2003
    Location:
    Lowell, Michigan USA
    Yes, the Z-Drive will operate on a battery. But if the battery isn't fairly fresh the sound from the pedal deteriorates. At least I've had it happen twice where I thought, "Things aren't sounding so good for some reason." Both times I plugged in a power supply and that solved the problem. I didn't measure the battery after. I should do that next time to establish some parameters.
     
    68Telebass likes this.
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.