1. Win a Broadcaster or one of 3 Teles! The annual Supporting Member Giveaway is on. To enter Click Here. To see all the prizes and full details Click Here. To view the thread about the giveaway Click Here.

Telecaster squeal/feedback - bridgeplate problem

Discussion in 'Telecaster Discussion Forum' started by Mr_Martin, Jan 25, 2021.

  1. Mr_Martin

    Mr_Martin Tele-Afflicted

    Posts:
    1,329
    Joined:
    Sep 21, 2009
    Location:
    Cologne, Germany
    I built a partcaster a while ago. So far so good.

    At higher Volumes there was a terrible squeal, i thought it's the pickup.
    So i put a Humbucker in it, same problem. So i read it could be the bridge plate.

    I bought a half bridge and tried it, problem solved.

    Nice sideeffect: because the humbucker is mounted direct to the body
    there is less harsh heights and a more "woody" tone, hard to describe.
    And i like the looks.

    Partcaster#1a.jpg

    Partcaster#2a.jpg
     
  2. Dacious

    Dacious Poster Extraordinaire

    Posts:
    9,284
    Joined:
    Mar 16, 2003
    Location:
    Godzone
    The bridgeplate can vibrate - two common tricks were small countersunk screws in leading edge, and melt wax from a candle and stick it down.
     
  3. Mr_Martin

    Mr_Martin Tele-Afflicted

    Posts:
    1,329
    Joined:
    Sep 21, 2009
    Location:
    Cologne, Germany
    This is my 10th Telecaster in my life but i never had this problem.
     
  4. Dacious

    Dacious Poster Extraordinaire

    Posts:
    9,284
    Joined:
    Mar 16, 2003
    Location:
    Godzone
    I'd say it's likely the bridge pickup is borderline.
     
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.