"Snap..Crackle..Pop"

Discussion in 'Amp Tech Center' started by Televised, May 8, 2017.

  1. Televised

    Televised Friend of Leo's

    Posts:
    2,283
    Joined:
    Apr 26, 2009
    Location:
    Portland, OR
    Picked up a used Jet City 20 watt amp head a few months ago. When I started using the effects loop I began to experience some significant popping noise....with the amp I mean.
    After nosing around Google, the symptoms seem to add up to "DC leakage".
    What's weird is that I'm only using one pedal in the effects loop and I only experience the problem when I'm using this pedal with the effects loop.
    Pretty simple solution was to quit using the effects loop and run all pedals in front of the amp. This is what I'm currently doing and it works fine but was just curious if anyone has come across effects loop popping before.

    Thanks
     
  2. Platefire

    Platefire Friend of Leo's

    Age:
    72
    Posts:
    3,417
    Joined:
    Nov 3, 2003
    Location:
    North Louisiana around Many
    Thinking??? I have worked on amps where there were jack switches not working properly on the effects loop and corrected it with some good contact cleaner. Spray contact cleaner in one jack at a time then work a 1/4 patch cord back and forth in the jack several times before the cleaner dries. Do it to both jacks. Then try it. Platefire
     
  3. robrob

    robrob Poster Extraordinaire Ad Free Member

    Posts:
    7,552
    Joined:
    Dec 29, 2012
    Location:
    United States
    Are the effects jacks mounted to a PCB? If yes the contacts might be breaking on the board.
     
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.