1. Win a Broadcaster or one of 3 Teles! The annual Supporting Member Giveaway is on. To enter Click Here. To see all the prizes and full details Click Here. To view the thread about the giveaway Click Here.

SCXD tube problem?

Discussion in 'Amp Central Station' started by telekaster1999, Jun 12, 2011.

  1. telekaster1999

    telekaster1999 Tele-Meister

    Age:
    52
    Posts:
    468
    Joined:
    Feb 22, 2008
    Location:
    Heath Springs SC.
    It started making cracking and poping noise yesterday, so I turned it off and tried it again this morning, same thing. Only mods are rajin cagun speaker and bumped up the bias a little. Could it be the power tubes?
     
  2. Axis29

    Axis29 Poster Extraordinaire Ad Free Member

    Posts:
    6,858
    Joined:
    Jan 2, 2007
    Location:
    Beaumont, CA
    Have you made sure all the tubes are seated tightly? That's the first thing I'd check....
     
  3. telekaster1999

    telekaster1999 Tele-Meister

    Age:
    52
    Posts:
    468
    Joined:
    Feb 22, 2008
    Location:
    Heath Springs SC.
    Yea, I did that this morning. Wished I lived a little closer to somewhere I could just go buy some tubes to try.
     
  4. RubyRae

    RubyRae Friend of Leo's

    Age:
    45
    Posts:
    4,252
    Joined:
    Dec 8, 2009
    Location:
    Cincinnati
    What guitar are you playing?
     
  5. fly135

    fly135 Tele-Holic

    Posts:
    597
    Joined:
    Dec 19, 2007
    Location:
    Orlando
    I had that once on my SCXD and it was the cable and input jack. Took it out and put it back in and it was fine. Run the line out into something you can hear and see if it's in the power amp or preamp.
     
  6. telekaster1999

    telekaster1999 Tele-Meister

    Age:
    52
    Posts:
    468
    Joined:
    Feb 22, 2008
    Location:
    Heath Springs SC.
    good idea.
     
  7. bug music

    bug music Tele-Afflicted

    Posts:
    1,078
    Joined:
    May 29, 2004
    Location:
    Taxachusetts
    Very good chance the power tubes are making that noise. My SCXD started doing that just after the 90 day warranty on the tubes was up. I replaced them with the same black glass tubes that Fender recommended (Groove Tubes 6V6-C's) and then they started making a crackling noise a couple of months later, while still under warranty. I returned them to Groove Tubes, and they sent me the EHX (Groove Tubes 6V6-R) instead, I've been running the EHX's for over 6 months now with no problems. I really don't trust those black glass Chinese tubes much now, even though they sound pretty good.

    Hopefully a set of tubes will fix it for you.

    - Jay
     
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.