1. Win a Broadcaster or one of 3 Teles! The annual Supporting Member Giveaway is on. To enter Click Here. To see all the prizes and full details Click Here. To view the thread about the giveaway Click Here.

Reverb Fails Intermittently on Fender Blues Jr.

Discussion in 'Amp Central Station' started by Hockey Rocker, Dec 13, 2008.

  1. Hockey Rocker

    Hockey Rocker Former Member

    Posts:
    1,164
    Joined:
    Jun 18, 2007
    Location:
    Gone
    Has anyone experienced this problem? My Fender Blues Jr. is a few years old and rarely leaves the house. Recently the Reverb went out. The next day it was back. The following day it was out again.

    I've checked the RCA jacks and they are in place but do get some strange, distant and muted, echo noises working when you jiggle them in place. Then the reverb just stays dead. It's a shame because I've been playing Rockabilly on my Tele lately and I miss the reverb.

    The amp sounds fine, but some days the reverb works, and some days it doesn't. Can you suggest anything that would save me a trip to the shop?

    Thanks very much.
     
  2. Billm

    Billm RIP

    Posts:
    2,227
    Joined:
    Mar 26, 2008
    Location:
    New Jersey
  3. Robin Nahum

    Robin Nahum Friend of Leo's

    Posts:
    2,273
    Joined:
    Mar 5, 2003
    Location:
    Sydney, Australia
    If it is failing with the footswitch plugged in but okay without it, it could be a short in the footswitch.
     
  4. Hockey Rocker

    Hockey Rocker Former Member

    Posts:
    1,164
    Joined:
    Jun 18, 2007
    Location:
    Gone
    Thanks guys. It's not a footswitch. I'll take a look at the wiring over the weekend. Thanks very much for the link and the help.
     
  5. Billm

    Billm RIP

    Posts:
    2,227
    Joined:
    Mar 26, 2008
    Location:
    New Jersey
    The footswitch doesn't control the reverb on a Blues Junior, so we can rule that out.
     
  6. DavyA

    DavyA Tele-Meister

    Posts:
    453
    Joined:
    Dec 19, 2006
    Location:
    Longmont Colorado
    I have had problems with one of mine (I have two). First I had a bad hummmm and it was fixed with a new cap. Then it went out again and replaced the cap with a bigger one. Then it went out yet again and I had to replace the spring unit.

    I would have someone check out the circut. Is it under warrantee? Mine is not because it has been modded. Including the reverb circut.

    Good luck!
     
  7. Stan Martin

    Stan Martin Tele-Afflicted Silver Supporter

    Posts:
    1,195
    Joined:
    Mar 22, 2003
    Location:
    USA
    I just fixed one

    and it was a broken wire by the transducer. a magnifying glass helped me find the break, because everything looked like it was connected.
     
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.