1. Win a Broadcaster or one of 3 Teles! The annual Supporting Member Giveaway is on. To enter Click Here. To see all the prizes and full details Click Here. To view the thread about the giveaway Click Here.

Princeton Reverb RI - New Owner "Is it Normal?" Questions

Discussion in 'Amp Central Station' started by joaters, May 18, 2020.

  1. naomimoan

    naomimoan TDPRI Member

    Posts:
    35
    Joined:
    Nov 17, 2018
    Location:
    Jersey
    Another PRRI owner chiming in.
    1. No pop or crackle plugging into instrument input 1, but interestingly there’s a little noise when plugging into 2 (not sure if I’ve ever used the 2nd input before- had the amp since ~2012)
    2. Tremolo kicks in around 5
    3. Volume pot is definitely stiffer than the others
     
  2. schmee

    schmee Doctor of Teleocity

    Posts:
    13,354
    Joined:
    Jun 2, 2003
    Location:
    northwest
    Tremelo could very likely be the bias setting on the power tubes. Princeton's are one of the Fender amps that drive the Tremelo from that. Unlike the Deluxe and larger amps.
    The other two things are likely inconsequential and not unusual ...on many amps anyway.
     
    corliss1 likes this.
  3. Geo

    Geo Friend of Leo's

    Age:
    71
    Posts:
    4,975
    Joined:
    Mar 17, 2003
    Location:
    Hendersonville, TN
    Plastic jack - could be static electricity buildup.
     
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.