Pop-Up ads - Help?

gabasa

Tele-Holic
Joined
Jan 29, 2018
Posts
725
Age
50
Location
Toronto, ON
This afternoon I started getting pop up ads when I go into the TDPRI website. This keeps coming up within seconds:

Screen Shot 2022-07-01 at 1.12.54 AM.png

Is anyone else having this issue? Would you happen to know a fix for it? It only happens on my computer with the TDPRI website, and I know it’s been a problem here in the past.

Mods? Are there any setting changes that can be made to avoid this?
 

Kiwi_Neil

Tele-Holic
Joined
Nov 8, 2016
Posts
524
Age
62
Location
New Zealand
This afternoon I started getting pop up ads when I go into the TDPRI website. This keeps coming up within seconds:

Is anyone else having this issue? Would you happen to know a fix for it? It only happens on my computer with the TDPRI website, and I know it’s been a problem here in the past.

Mods? Are there any setting changes that can be made to avoid this?

You don't have an Adblocker running on your machine? I do and I never get these kinds of problems. It's also good to scan (say) monthly for Malware etc etc
 

bgmacaw

Poster Extraordinaire
Joined
Feb 11, 2006
Posts
9,995
Location
Near Athens GA USA
Adblockers, hosts file, VPN or the like will help you get rid of this annoyance everywhere.

It does look like ad script coders have found a new way to inject sneaky redirects into Google ads again while evading some ad blocking. I had one of these redirects happen on my phone yesterday where there are fewer blocking options. Google was doing a good job of combating them for a while but it looks like they've gone back to letting them slip through.
 

gabasa

Tele-Holic
Joined
Jan 29, 2018
Posts
725
Age
50
Location
Toronto, ON
Thanks everyone for the comments.

I've never used an adblocker before because this has never been an issue for me. Perhaps it doesn't happen as much on a Mac. The ads were popping up when I used Firefox, so I switched to Chrome and the problem vanished. This made me think that perhaps my Firefox needed updating; I did just that and the problem vanished.

I guess that at the very least, we need our browsers up to date all the time.
 




Top