pedalboard: "weeeeeep!!!"

Discussion in 'The Stomp Box' started by braveheart, Aug 25, 2019.

  1. braveheart

    braveheart Tele-Meister

    Posts:
    238
    Joined:
    Apr 15, 2018
    Location:
    here,there and everywhere
    after a long time of joy, my pedalboard suddenly sounds "squeaky".
    I turned on my MXR 5150/Morley Wah,Bogner pedals (not at once) and a loud feedback-ish high-frequency tone (weeeeeeeep!) was screaming through the speakers.

    But that was just the tip of the iceberg. My overall tone with pedals bypassed has also an ugly feedback-ish/HF-ish undertone...you don't hear the bleep, but it's there...everything sounds harsh and ugly

    I had that before, years ago, but I can't remember exactly what it was... the nature of the symptoms tells me, it could be the the power supply (cables)
    what do you think?
     
  2. Alamo

    Alamo Doctor of Teleocity Silver Supporter

    Posts:
    10,921
    Joined:
    Nov 15, 2006
    Location:
    Berlin
    Could be anything. check and go through the signal chain, starting from the guitar.
    but if you have hunch what it could be, go there first.
    good luck
     
    braveheart likes this.
  3. coloradojeff

    coloradojeff Tele-Holic

    Posts:
    720
    Joined:
    Feb 17, 2012
    Location:
    Colorado
    I think you're on the right track to check the power supply to the pedals.
     
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.