1. Win a Broadcaster or one of 3 Teles! The annual Supporting Member Giveaway is on. To enter Click Here. To see all the prizes and full details Click Here. To view the thread about the giveaway Click Here.

Pedal Causing Hum

Discussion in 'The Stomp Box' started by mistermullens, Feb 20, 2015.

  1. mistermullens

    mistermullens Poster Extraordinaire

    Posts:
    5,746
    Joined:
    Jan 3, 2007
    Location:
    Atlanta Area
    So, I have an MI Audio Blues Pro. I believe it is Ver 2, and I've had it for 5 years. I absolutely this pedal, but it starting producing a loud hum through my amp when plugged in whether I've kicked it on or not. Here's the troubleshooting I've done.

    1. The pedal is the only thing between my guitar and amp
    2. I have tried a number of different patch cables when used with other pedals.
    3. I've also used different guitar cables
    4. I tested my setup with a different OD pedal and have removed OD pedals from the chain altogether
    5. I continue to get the same amount of hum with a power supply or with a battery
    6. It happens in different rooms

    Anything else you guys can think of for me to test? Any ideas on what the problem could be? I'd love to be able to fix it myself, but I've only done wiring on guitars.
     
  2. waparker4

    waparker4 Doctor of Teleocity Ad Free Member

    Posts:
    18,996
    Joined:
    Nov 9, 2011
    Location:
    Philadelphia, PA
    Happens in bypass, so I'd suspect the switch and jacks. I'd unmount each jack and remount it, you can also clean the metal contacts of the jack with contact cleaner and also the contact between the jack and the metal enclosure. There could be corrosion in any of those places causing a poor connection. If not that it could be a solder joint on the switch or on the jacks I'm guessing.
     
  3. luckett

    luckett Banned

    Posts:
    3,614
    Joined:
    Jun 14, 2011
    Location:
    .
    If you have a multimeter, put the pedal in bypass and touch the probes to the metal part of the plugs on the two cables where they go into the jacks. Then put the probes on the tips of the other ends of the cables. It should read zero resistance for both. If not, you have some kind of ground or continuity problem with the jacks or switch like waparker4 describes. If you don't have a multimeter, plug the pedal into your guitar and amp. Get a piece of wire and bridge it between the metal part of the plugs and see if the hum goes away. If it goes away, then you have a ground problem somewhere in the pedal.
     
  4. ICTRock

    ICTRock Tele-Afflicted

    Posts:
    1,640
    Joined:
    Jul 31, 2014
    Location:
    Tampa,FL
    if its not grounding then its a capacitor
     
  5. mistermullens

    mistermullens Poster Extraordinaire

    Posts:
    5,746
    Joined:
    Jan 3, 2007
    Location:
    Atlanta Area
    Thanks for the tips.

    If it is a capacitor, who do I figure out which one?
     
  6. ICTRock

    ICTRock Tele-Afflicted

    Posts:
    1,640
    Joined:
    Jul 31, 2014
    Location:
    Tampa,FL
    probably one of the two 100uf caps
     
  7. bricksnbeatles

    bricksnbeatles Tele-Afflicted

    Posts:
    1,730
    Joined:
    Apr 8, 2014
    Location:
    Long Island, NY
    I'd love if humming caused pedals, I'd be humming up a vintage fuzz face right now!
     
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.