1. Win a Broadcaster or one of 3 Teles! The annual Supporting Member Giveaway is on. To enter Click Here. To see all the prizes and full details Click Here. To view the thread about the giveaway Click Here.

New Filter Caps...

Discussion in 'Amp Tech Center' started by Kilofunk, Jan 18, 2014.

  1. Kilofunk

    Kilofunk TDPRI Member

    Posts:
    49
    Joined:
    May 15, 2011
    Location:
    Ohio, U.S.A.
    Hey all, hope everyone is having a nice Saturday night. I have a question for the gurus here... I replaced the filter caps in my Laney GC30-V this week and all is well with that, my concern is with the way they "died" on me... it seems that the Cap for the screen grid node was the one that failed first. I figure this because of the symptom... I would hit a big E chord and the signal would drop off in the same manner you would hear if you unplugged the battery from your non-true bypass pedal and then plugged it back in... when this would happen the power tubes would ... uh ... glitch. No flashing or arching that i could see, the blue glow would die off and then re-appear with the signal.

    All seems fine now but I wonder what damage might have been done to my pwr tubes... the B+ is down about 11 volts at the first node but it was like that before... any thoughts on or experience with this type of failure?

    Any input would be nice... thanks in advance, Funk.
     
  2. BiggerJohn

    BiggerJohn Friend of Leo's

    Posts:
    3,311
    Joined:
    Jun 1, 2009
    Location:
    California
    Doubt the tubes were damaged. If you lost screen voltage the tube current would drop off sharply. doesn't hurt anything.
     
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.