1. Win a Broadcaster or one of 3 Teles! The annual Supporting Member Giveaway is on. To enter Click Here. To see all the prizes and full details Click Here. To view the thread about the giveaway Click Here.

Marshall Haze Channel Switching

Discussion in 'Amp Tech Center' started by IanC_UK, Feb 25, 2021.

  1. IanC_UK

    IanC_UK NEW MEMBER!

    Age:
    50
    Posts:
    2
    Joined:
    Feb 25, 2021
    Location:
    UK
    Hi. Anyone any idea what could be causing my Marshall Haze 15 head to switch channels ok with the footswitch but not with the front panel button?

    I've unplugged the footswitch and no joy switching channels...tried cleaning the switch mechanism and still nothing

    Other than the above, the amp works fine and sounds great

    Cheers,

    Ian
     
  2. goldguitarguy

    goldguitarguy Tele-Meister

    Posts:
    369
    Joined:
    Oct 4, 2010
    Location:
    Alberta,canada
    Probably a bad switch
     
  3. goldguitarguy

    goldguitarguy Tele-Meister

    Posts:
    369
    Joined:
    Oct 4, 2010
    Location:
    Alberta,canada
    Did you try cleaning the shunt contacts on the TRS jack for the foot switch? Or inspecting the foot switch jack? If those shunts dont contact properly after the foot switch plug is removed the amp acts like the foot switch is still engaged bypassing the panel switch....
     
    IanC_UK likes this.
  4. IanC_UK

    IanC_UK NEW MEMBER!

    Age:
    50
    Posts:
    2
    Joined:
    Feb 25, 2021
    Location:
    UK
    Cheers goldguitarguy, much appreciated. Makes a lot of sense and sounds like a job for a Saturday morning with a coffee.
     
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.