1. Win a Broadcaster or one of 3 Teles! The annual Supporting Member Giveaway is on. To enter Click Here. To see all the prizes and full details Click Here. To view the thread about the giveaway Click Here.

Help with the Keeley/Ross 5-knob comp

Discussion in 'Burnt Fingers DIY Effects' started by Mark the Moose, Mar 27, 2020.

  1. Mark the Moose

    Mark the Moose Tele-Holic

    Age:
    45
    Posts:
    914
    Joined:
    Sep 4, 2018
    Location:
    Erie, CO
    I built a Ross Comp with Keeley mods, 5-knob job, but I'm having troubles. I don't have a schematic, just the stripboard layout from tagboard. It has a blend knob, and the clean side of the circuit works fine. However as I turn the blend knob to the compressed side there's no sound coming through. Now if I crank the clip knob and really strum hard it will suddenly come on crazy loud, then, just as suddenly switch the sound off.

    I've gone over the placement of components several times and knifed the gaps between the copper strips but can't seem to get this right.

    Any suggestions?
     
  2. awasson

    awasson Poster Extraordinaire Gold Supporter

    Age:
    56
    Posts:
    5,680
    Joined:
    Nov 18, 2010
    Location:
    Vancouver
    I’d check the jumpers and voids to make sure they’re correct. There are several jumpers that join in the same hole on the right side of the board. I’ve built a lot of Tagboard Effects circuits and it’s usually something like a missed or misplaced jumper that trips me up.

    Also as MAO suggested check the transistor orientations.
     
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.