Help me Troubleshoot Fender HRD

BoomTexan

Tele-Meister
Joined
Sep 20, 2021
Posts
217
Age
18
Location
Houston
So, I bought a capacitor kit that is the exact same specs as the filter caps on my Fender HRD. The old ones were leaking and I just didn't want to deal with the hum. I replaced them and have been having problems recently. Here's a video of what happens when I turn it on. There's a light constant noise when on standby and when turned on, it makes this awful loud humming noise. Any ideas on what could've happened? When I first tried this it made like the worst popping noise I've ever heard on one of these amps. Then, I reheated the ground wire connection and it was replaced by this loud hum. I've checked and doublechecked everything and have no idea what to do. Should I try replacing all the capacitors (even the unleaky ones?).


 

BoomTexan

Tele-Meister
Joined
Sep 20, 2021
Posts
217
Age
18
Location
Houston
I think you need to reinstall the board. The board may have a ground connection on the stand-off that is not connected
Well, actually, I just figured it out. The board was leaning on one of the posts that's drilled into the chassis. A capacitor ground was touching a post. I had already grounded the board, and when that one touched ground again, it created a ground loop. I'm gonna install the other capacitors I mentioned in the video (just to finish the job entirely), remount, and then turn it on. Hopefully it'll be working then...
 

Dacious

Doctor of Teleocity
Joined
Mar 16, 2003
Posts
10,448
Location
Godzone
I'd replace all the caps. I can't see those but they look like the 450 VDC early caps. Hopefully the new kit is 500vdc..there's also bypass caps on the board. They should all be replaced if it's a 90s.
 




Top