Help: "Comp" control doesn't work!

Discussion in 'The Stomp Box' started by braveheart, Dec 8, 2019.

  1. braveheart

    braveheart Tele-Holic

    Posts:
    620
    Joined:
    Apr 15, 2018
    Location:
    here,there and everywhere
    The "comp" control on my Visual Sound Comp 66 doesn't react.
    The compressor effect level is 100% all the time.

    I bought it used very cheap and I guess the seller wasn't aware of the malfunction

    Everything else works as it should (tone,gain etc.)

    I haven't checked it with my multimeter...but would you say, it's just a faulty pot?
     
  2. wabashslim

    wabashslim Tele-Holic

    Age:
    68
    Posts:
    908
    Joined:
    Nov 26, 2005
    Location:
    Sonorous Desert
    That's the easiest possibility out of many. Probably not though.
     
    braveheart likes this.
  3. sirbergersworth

    sirbergersworth Tele-Holic

    Posts:
    547
    Joined:
    Aug 30, 2011
    Location:
    St. Louis, MO
    Maybe the knob is spinning on the pot shaft?
    Sounds silly but I’ve missed sillier stuff.
     
    braveheart likes this.
  4. wabashslim

    wabashslim Tele-Holic

    Age:
    68
    Posts:
    908
    Joined:
    Nov 26, 2005
    Location:
    Sonorous Desert
    I have an old MXR Dyna-comp that started acting "different" years ago. It still compressed, but more like a hard limiter than a ratio'd compressor. Had another, maybe a Boss, that stopped compressing and turned into a clean boost. Analog compressors by their nature can get weird just from some slight shifts of parts values and troubleshooting them is a tough nut to crack.
    I looked at this Comp 66 on Youtube, they seem pretty decent.
     
    braveheart likes this.
  5. Peegoo

    Peegoo Tele-Holic

    Age:
    59
    Posts:
    726
    Joined:
    Oct 11, 2019
    Location:
    USA
    If blasting the pot with a non-lube cleaner (DeOxIt) does not clear up the problem, send it back for a refund.
     
  6. braveheart

    braveheart Tele-Holic

    Posts:
    620
    Joined:
    Apr 15, 2018
    Location:
    here,there and everywhere
    yeah,it became a bit better with DeOxit...
     
  7. braveheart

    braveheart Tele-Holic

    Posts:
    620
    Joined:
    Apr 15, 2018
    Location:
    here,there and everywhere
    the comp 66 is a great compressor/booster...very musical and versatile...I also have the Route66 V2 which is the comp66+808 ...killer pedal
     
  8. braveheart

    braveheart Tele-Holic

    Posts:
    620
    Joined:
    Apr 15, 2018
    Location:
    here,there and everywhere
    no...
     
    sirbergersworth likes this.
  9. schenkadere

    schenkadere Friend of Leo's

    Age:
    53
    Posts:
    4,666
    Joined:
    May 13, 2009
    Location:
    NY
    V2 has a lifetime warranty. Just pay shipping. Quick turn around. Just need to fill out the form online.
     
    Last edited: Dec 9, 2019
    bluesholyman likes this.
  10. bluesholyman

    bluesholyman Tele-Afflicted

    Posts:
    1,551
    Joined:
    Nov 10, 2013
    Location:
    Greater Atlanta
    I agree with @schenkadere - I had an Open Road with a bent shaft on one of the pots, obviously not a warranty issue, and they were like "send it in and we'll take care of it" - came back like new, only paid shipping. I think it was out/back in less than a week - great service.
     
    RetroTeleRod likes this.
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.