Got a Double Fuzz, $20 off.

Discussion in 'The Stomp Box' started by Whatizitman, Aug 25, 2019.

  1. Whatizitman

    Whatizitman Friend of Leo's

    Posts:
    2,124
    Joined:
    Feb 18, 2018
    Location:
    WV
    SA had a $20 off anything over $50. Sooooo... looked for a $50 pedal. $57, good reviews. Boo yah.

    I guess the nano version is the only one available now. I’m ok with that, but it might make it tougher to repair or mod? No biggie. Hope it’s as good as the interwebz says it is.

    Luv those type of coupons. I rarely do big purchases, so the 15-20% off deals really don’t do much for me. I’m a sucker for cheap gear for, uh, cheap.
     
  2. dswo

    dswo Tele-Meister

    Posts:
    446
    Joined:
    May 1, 2016
    Location:
    East Carolina
    That's a good deal you found.
     
  3. Whatizitman

    Whatizitman Friend of Leo's

    Posts:
    2,124
    Joined:
    Feb 18, 2018
    Location:
    WV
    Worked for about 10mins. Then, not. Bypasses fine. Turn on, LED lights up. Nada. Tried new battery. Same. Sometimes there will be sound for a half second. Then nothing.

    Man, I have just had the worst luck with pedals. Oh well. Back it goes.
     
  4. J-Flanders

    J-Flanders Tele-Meister

    Posts:
    110
    Joined:
    Aug 4, 2016
    Location:
    Flanders
    Double Fuzz???
    You mean Double Muff? Big Muff?
    I assume EHX since you speak of nano?
     
    Whatizitman likes this.
  5. Whatizitman

    Whatizitman Friend of Leo's

    Posts:
    2,124
    Joined:
    Feb 18, 2018
    Location:
    WV
    Yeah, EHX nano double muff. Thanks for pointing that out. I totally missed that I did that haha.

    SA told me to just keep it, and they are refunding the total. Very nice of them!

    I guess I can try and see if I can get it to work. But so far my pedal diagnostic skills are hit and miss, at best.
     
  6. wildschwein

    wildschwein Tele-Afflicted

    Posts:
    1,605
    Joined:
    Feb 3, 2009
    Location:
    Perth, Western Australia
    Great pedal -- one of my faves. Maybe you'll get it working. Probably a cold/cracked solder joint somewhere.
     
  7. telemnemonics

    telemnemonics Doctor of Teleocity Ad Free Member

    Age:
    59
    Posts:
    16,379
    Joined:
    Mar 2, 2010
    Location:
    Maine
    Or a jack rotated and is grounding a lug to the case etc.

    That would be all board mounted SMT though, not much can move...

    I have like a dozen muffs, can't get enough!
     
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.