Fluctuating Bias Current 65 PRRI

Discussion in 'Amp Tech Center' started by DennisM, Jul 20, 2017.

  1. DennisM

    DennisM Tele-Meister

    Posts:
    170
    Joined:
    Nov 18, 2013
    Location:
    Nevada
    Just tried to adjust the bias current on my PRRI, and when I got the meter on it is was like....bing bing bing, 21, 17, 24, 18, 23, 25, 17, 22...changed every half second. I adjusted it a few months ago and it was nice and steady. I checked the wall voltage, changed 6V6's, changed out the 5Y3 and it still did it. Ideas?
     
  2. robrob

    robrob Poster Extraordinaire Ad Free Member

    Posts:
    7,553
    Joined:
    Dec 29, 2012
    Location:
    United States
    How's the battery in your meter?
     
  3. DennisM

    DennisM Tele-Meister

    Posts:
    170
    Joined:
    Nov 18, 2013
    Location:
    Nevada
    Good point. Never thought of that. It's probably weak. I just used it for a couple weeks straight on my 5e3 build. I'll check it. Thanks!
     
  4. Mhat

    Mhat Tele-Meister

    Age:
    38
    Posts:
    350
    Joined:
    Mar 17, 2003
    Location:
    Austin,TX
    Set the tremolo speed and intensity to zero. That'll fix it.
     
    Last edited: Jul 20, 2017
    Thin69, robrob and Phrygian77 like this.
  5. DennisM

    DennisM Tele-Meister

    Posts:
    170
    Joined:
    Nov 18, 2013
    Location:
    Nevada
    Boy. Talk about feeling stupid. Yep, it was the battery. Good Lord. Thanks Rob!
     
    corliss1 and robrob like this.
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.