Fender g-dec 30

Rosopas 1990

TDPRI Member
Joined
May 15, 2022
Posts
4
Age
42
Location
Croatia
Imam fender g-dec pojačalo koje nisam dugo koristio. Sad ga upalim, zvuci rade, lcd zaslon svijetli, ali ništa ne pokazuje.
Ima li netko savjet što bi mogao biti uzrok?
Hvala vam
 

PCollen

Friend of Leo's
Joined
May 7, 2010
Posts
4,179
Location
Space Coast, FL
Imam fender g-dec pojačalo koje nisam dugo koristio. Sad ga upalim, zvuci rade, lcd zaslon svijetli, ali ništa ne pokazuje.
Ima li netko savjet što bi mogao biti uzrok?
Hvala vam
As I understand your post, you have a G-dec amp that you haven't used or even turned on in a long time. Now you have turned it on again, and the LCD screen lights up, but shows no information on the screen. But when you plug in a guitar to the G-dec amp you do get sound.
Is this correct ?

Has your G-dec been exposed to very hot or cold temperatures , like maybe being left in your car outside in winter or summer ? Temperature extremes can damage LCD screens.

When turned on and with a guitar plugged in :

Do the volume and tone knobs function properly ?

If you rotate the G-dec control knob next to the LCD screen , does the sound change ?
 
Last edited:

Rosopas 1990

TDPRI Member
Joined
May 15, 2022
Posts
4
Age
42
Location
Croatia
Thank you for your reply.
The amplifier was only in the room. Everything works, tones, drums, volume, only I don't see anything happening on the screen. I checked the flat cables, I think everything is fine, the voltages coming to the board are ok. Isn't the display a church?
 

Rosopas 1990

TDPRI Member
Joined
May 15, 2022
Posts
4
Age
42
Location
Croatia
The last sentence was misspelled (my bad English). Correct: maybe the lcd screen died after all?
How do I check?
 

PCollen

Friend of Leo's
Joined
May 7, 2010
Posts
4,179
Location
Space Coast, FL
The last sentence was misspelled (my bad English). Correct: maybe the lcd screen died after all?
How do I check?
Thank you for your reply.
The amplifier was only in the room. Everything works, tones, drums, volume, only I don't see anything happening on the screen. I checked the flat cables, I think everything is fine, the voltages coming to the board are ok. Isn't the display a church?
Below is a discussion thread related to a Fender Mustang III LCD problem that might give you some ideas where to check. But you will have to get access to the circuit board area, inside the amp, to do so. Myself, I really have never had this problem with the two Fender digital amps I have, Mustang III V.2 and a LT25. I have had a few LCD wrist-watch displays just stop working.

Click on this link below to access the discussion thread about the Mustang III LCD:


Here is another discussion thread about a Fender LT25 amp with a blank screen that suggests perhaps someone tried to do a FACTORY RESTORE but did not have a USB cable connected between the amp and a computer with internet. It's an interesting possibility. Do you have a Fender G-dec manual for reference to how the amp operates ?

 
Last edited:




Top