Fender Frontman 65R Problem

Discussion in 'Amp Central Station' started by works, May 15, 2019.

  1. works

    works NEW MEMBER!

    Age:
    30
    Posts:
    2
    Joined:
    May 14, 2019
    Location:
    italy
    Hi to everybody! :)

    Yesterday my amp started acting weird and smelling, i opened it and...
    i found R76, R80 and R82 completely burnt.
    Surrounding 1N4148, tansformer and caps are fine.
    Now i'm trying to desolder & test all the transistors...have you something to suggest to look at?

    Thanks!!!
     
  2. Lord_Ingipz

    Lord_Ingipz Tele-Meister

    Posts:
    488
    Joined:
    May 13, 2015
    Location:
    Cicero, IL
    Take it to a tech? My hunch is caps or maybe a short?
     
  3. works

    works NEW MEMBER!

    Age:
    30
    Posts:
    2
    Joined:
    May 14, 2019
    Location:
    italy
    i'm a technician :)
    As i said, i've already tested caps & everything else beside the transistors
    I was asking if there is a transistor that happens to fail "commonly" on this amp, as happens with others!
     
  4. kirby02

    kirby02 TDPRI Member

    Posts:
    8
    Joined:
    Apr 16, 2014
    Location:
    Anniston, AL
    You will get no help from Fender on this amp. I have a Frontman 65R and when I ask for assistance they told me that any Fender amp that sells for under $250 is not supported after the warranty has expired. In the process of troubleshooting my amp I ran across a thread that sounds like your problem. Check R83 for a high (not open) resistance. He stated R76, R80, and R81 was open and he replaced Q9 2SA1016K, Q10 2SA1013 and Q11 2SC2383. Hope this helps.
     
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.