Fender Blues Deville 2x12 "Bass" issue

Discussion in 'Amp Tech Center' started by Neener, Jan 25, 2020.

  1. Neener

    Neener Tele-Holic

    Posts:
    506
    Joined:
    Apr 19, 2019
    Location:
    Detroit
    Managed to find a 90's MIA Blues Deville 2x12 this week off craigslist. While playing, I noticed the "bass" pot really doesn't do much. If you turn it lower than "2" you lose all low end, but from 2-10, it's sounds about the same. There's low end but value doesn't seem to change.

    I have a Hot Rod version and the bass seems to be more responsive.

    Any idea what the issue is?
     
  2. Alamo

    Alamo Doctor of Teleocity

    Posts:
    11,252
    Joined:
    Nov 15, 2006
    Location:
    Berlin
    Turn the middle pot to zero and try the bass again. that's where the frequencies overlap a lot.
    the mid pot is the bees knees, bass just to fine tune a bit. IMHO.
     
    Neener likes this.
  3. Neener

    Neener Tele-Holic

    Posts:
    506
    Joined:
    Apr 19, 2019
    Location:
    Detroit
    That actually did help quite a bit...

    I know the amps had some work done, so maybe repairs altered it

    But thank you for the tip!
     
    Alamo likes this.
  4. Wally

    Wally Telefied Ad Free Member

    Posts:
    34,347
    Joined:
    Mar 17, 2003
    Location:
    Lubbock, TX
    If you are @ccustomed to BF type preamps, the preamp 8n that amp will be a different animal. It is based on the 5F6A Bassman, and the tone controls are placed further down in the signal chain. They react differently.
     
    Neener likes this.
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.