Asher Guitars WD Music Products Amplified Parts Mod Kits DIY Nordstarnd Pickups darrenriley.com
Asher Guitars WD Music Products Amplified Parts Mod Kits DIY Nordstarnd Pickups Warmoth.com
Asher Guitars WD Music Products Amplified Parts Mod Kits DIY Nordstarnd Pickups Warmoth.com

DRRI goes silent?

Discussion in 'Amp Central Station' started by 8barlouie, Aug 8, 2018.

  1. 8barlouie

    8barlouie Friend of Leo's Silver Supporter

    Age:
    59
    May 9, 2015
    Seekonk, MA
    My DRRI just went quiet. It’s about 4 years old. I play it about 5-6 hours a week. Only maintenance I’ve done is replace v1 and v2 with EHX 12ax7s because the originals got noisy.

    Recently, it’s been noisy again with that radio static you get when a preamp tube gets noisy. I decided to live with it for time being. Today, I turned it on and got some fairly loud hum, then a crackle and dead silence.

    I checked the fuse, the connections, and all the inputs. Both the power tubes glow orange when turned on, but not so much for the preamp tubes. I pulled v1, nothing. Tried switching v1 and v2, nothing. In my experience, I’ve never messed around past v2. I’m not even sure if I can tell if a tube is blown when I see one.

    I guess after four years, maybe it is due for a trip to the amp guy, but I sure would like to avoid it if I can. Any ideas?
     

  2. schmee

    schmee Friend of Leo's

    Jun 2, 2003
    northwest
    It could just be a power tube or the rectifier tube. They often blow a fuse when they are failing.
    Less likely is a filter cap, they are known for leaking in some amp build date time frames...
     
    Last edited: Aug 8, 2018
    8barlouie likes this.

  3. strat a various

    strat a various Friend of Leo's

    May 9, 2008
    Texas
    Check the speaker cable.
     
    viccortes285 and 8barlouie like this.

  4. 8barlouie

    8barlouie Friend of Leo's Silver Supporter

    Age:
    59
    May 9, 2015
    Seekonk, MA
    Check
     

  5. Silverface

    Silverface Poster Extraordinaire Platinum Supporter

    Age:
    66
    Mar 2, 2003
    Lawndale CA
    Are you testing it with a different cable/guitar, without a cable and is it absolutely dead quiet?

    If it is DEAD silent the problem is the speaker; speaker cable; power tubes; driver tube (and associated). It will not be a preamp issue or you would have some hum or hiss from the power amp, which consists of everything from V6-on (the last small tube is not a preamp tube - it's the driver. aka phase inverter, and part of the power amp).

    If you don't work on your own amps you're better off taking it to your amp tech after confirming the speaker cable is 1(plugged in) and 2) connected to both tabs on the speaker terminal. If you swap tubes around and something makes a sound would you know what it meant? If not - take it to a tech.
     
    viccortes285, Wally and 8barlouie like this.

  6. TeleV

    TeleV Tele-Holic

    534
    Mar 10, 2008
    Philadelphia, PA
    Are you the original owner and if so do you have your receipt? I ask because I thought the warranty on a DRRI is 5 years...at least it used to be years ago when I owned one. Would not hurt to check warranty status is what I’m saying....good luck!
     
    8barlouie likes this.

IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.