Bugera 1960 user help.

Discussion in 'Amp Central Station' started by Britpoper, Jun 19, 2019.

  1. Britpoper

    Britpoper TDPRI Member

    Age:
    51
    Posts:
    11
    Joined:
    Apr 7, 2019
    Location:
    Uk
    Hi peeps
    Just need a little advice.I think I might be dumb but 2 of the channels have really low volume needs to be cranked full for it to be loud untill I use both volume pots makes it a loud as hell is this correct?
    Thanks everyone.
     
  2. Paul G.

    Paul G. Friend of Leo's

    Posts:
    2,622
    Joined:
    Mar 17, 2003
    Location:
    Rhode Island
    Read the instructions. The bottom 2 inputs are cascading type, so you need both volumes cranked as it is feeding one channel into the other. Use the Parallel inputs on top and the channel volumes work normally, but you are still plugged into both volumes in parallel.

    Top left -- channels jumped internally in parallel, hi gain. Top right -- same, low gain.
    Bottom left -- channels jumped internally in series, hi gain. Since they're in series, both volumes must be open to get signal. Bottom right -- same, low gain.
     
  3. Britpoper

    Britpoper TDPRI Member

    Age:
    51
    Posts:
    11
    Joined:
    Apr 7, 2019
    Location:
    Uk
    Thanks for that.
    My other question is there is some audible hiss.I am thinking maybe preamp valves or is it nature of the beast?
     
  4. teleplayr

    teleplayr Tele-Holic

    Posts:
    820
    Joined:
    Feb 7, 2012
    Location:
    Nicoma Park, Oklahoma
    Anytime you have a cranked pre-amp your going to introduce more noise into the amp.
     
  5. Britpoper

    Britpoper TDPRI Member

    Age:
    51
    Posts:
    11
    Joined:
    Apr 7, 2019
    Location:
    Uk
    The hissing is there at low volume also.
    Thanks
     
  6. Paul G.

    Paul G. Friend of Leo's

    Posts:
    2,622
    Joined:
    Mar 17, 2003
    Location:
    Rhode Island
    It is a very, very, very bright amplifier, there is hiss as the high frequencies just pass straight through. That's why I sold mine, it just was uncontrollably bright and somewhat brittle to my ears.

    If it wasn't a PCB amp or if I could have gotten a schematic I would have modded it, but no such thing existed and I wasn't about to try to trace a 2-sided PCB.
     
    Orpingtons likes this.
  7. Orpingtons

    Orpingtons Tele-Meister

    Posts:
    136
    Joined:
    May 17, 2019
    Location:
    U.S.
    That's the problem with PCB amps, and most brand-name tube amps are PCB amps too. Can't say I like that.
     
    Paul G. likes this.
  8. Britpoper

    Britpoper TDPRI Member

    Age:
    51
    Posts:
    11
    Joined:
    Apr 7, 2019
    Location:
    Uk
    Thanks for that.
    I can agree with you with that but I am using it as a clean platform at low volume using pedals but I have the clean when needed.
    I was gonna pop some new preamps in to see if it made any difference .
    The hiss is acceptable but I just wanted to make sure that there isn't a fault.
     
IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.