Asher Guitars WD Music Products Amplified Parts Mod Kits DIY Nordstarnd Pickups darrenriley.com
Asher Guitars WD Music Products Amplified Parts Mod Kits DIY Nordstarnd Pickups Warmoth.com
Asher Guitars WD Music Products Amplified Parts Mod Kits DIY Nordstarnd Pickups Warmoth.com

Brand new CVC tele... dead pickup out of the box

Discussion in 'Squier Tele Forum' started by astroop, Aug 7, 2018.

  1. astroop

    astroop NEW MEMBER!

    2
    Aug 7, 2018
    Boston
    Curious to see if anyone else has had this problem... Was very excited today when FedEx rolled up and delivered my classic vibe custom tele. Eager to get playing, I opened it up only to find out the neck pickup was completely dead. Tried swapping out cable/amp, but still nothing. Bridge pickup worked great, but any time I selected the neck pickup, there was no sound. Going through the exchange process now with zzounds.com. Has anyone else experienced anything similar?
     

  2. Fendereedo

    Fendereedo Friend of Leo's

    Age:
    52
    Jan 1, 2014
    UK
    Could be a loose connection somewhere. Better to exchange it though, as opening it up could screw with your warranty.
     
    nicod98 likes this.

  3. Ira7

    Ira7 Poster Extraordinaire

    Age:
    61
    Jan 8, 2008
    Coral Springs, FL
    Just remove the two screws holding the control plate/cover on.

    See that no wires are loose and just hanging out. Then, let the whole assembly dangle (pull it out a little) and plug her in.

    Sometimes, when they screw the plate on, exposed wires cross what they're not supposed to cross and short stuff out, because it's all just "crammed" in there.
     

  4. Chunkocaster

    Chunkocaster TDPRI Member

    27
    Aug 10, 2018
    In space with Ziggy
    Send it back for a replacement unless you love the body and neck woods, weight.
    If you got a nice light one with flame neck or nicely matched top i'd just buy a upgrade neck pup for it if trouble shooting the current one fails. The neck pup is the classic vibes only shortfall imo. That and the output jack cup, replaced mine with a 5 dollar electrosocket.
     
    Last edited: Aug 14, 2018 at 3:40 AM
    rze99 likes this.

  5. VintageSG

    VintageSG Friend of Leo's Ad Free Member

    Mar 31, 2016
    Yorkshire
    If it's dead in the middle position, it's likely a short in either the pickup or a wire whisker on the switch.
    If it's working bridge only in the middle position, it's likely open circuit in the pickup.
    Either way, unless it's a real looker and player, send it back.
     
    Iago likes this.

  6. claes

    claes Tele-Holic

    616
    Aug 20, 2007
    sweden
    Happened to my classic 60's fender....new un box. My point is that its not a squier thing.
     

  7. brobar

    brobar Tele-Holic

    Age:
    43
    852
    May 30, 2017
    Colorado
    Own three classic vibes that did not have that problem (two of them were used though).

    It very well could be a simple fix, but if new... I would want it working out of the box too so exchange it on their dime.
     

  8. brookdalebill

    brookdalebill Telefied Ad Free Member

    Age:
    61
    Nov 15, 2009
    Austin, Tx
    Howdy, and welcome.
    Did you try another guitar cord?
    Sometimes the input jack will shift and short out, too.
    Lastly, I'd put an Electrosocket on it ASAP.
    Good luck!
     

  9. 8barlouie

    8barlouie Friend of Leo's Silver Supporter

    Age:
    59
    May 9, 2015
    Seekonk, MA
    I’m surprised the seller doesn’t give the guitar a once over before shipping.
     
    rze99 likes this.

  10. brobar

    brobar Tele-Holic

    Age:
    43
    852
    May 30, 2017
    Colorado
    That's why when it comes to buying new I buy through Sweetwater.

    But even then, through jostling around over 1,500 miles of shipping... things can still come loose. It happens, but thankfully not too often.
     
    8barlouie likes this.

  11. noah330

    noah330 Friend of Leo's

    Feb 10, 2009
    Maryland

  12. rze99

    rze99 Poster Extraordinaire Silver Supporter

    Feb 26, 2014
    South London UK
    I had this once with a MIM. The issue was a connection that wasn't soldered, just attached and looped through the switch eyelet.

    Anyway if not happy or happy making a fix, send back.
     

  13. astroop

    astroop NEW MEMBER!

    2
    Aug 7, 2018
    Boston
    Thanks for the input everyone. I ended up exchanging for a new one. FWIW, Zzounds was great during the whole process. They sent me a prepaid shipping label, and as soon as UPS scanned the item during drop off, they sent out the replacement with 1 day shipping. I'm absolutely loving this guitar so far.
     
    Iago likes this.

IMPORTANT: Treat everyone here with respect, no matter how difficult!
No sex, drug, political, religion or hate discussion permitted here.