$vboptions[bbtitle]

Odd things going on with my Fender Bassman 100

mercymercyme03
May 24th, 2010, 02:26 PM
So i bought a Fender Bassman 100 head on ebay. Seller said it was all original, and this turned out to be false. Its had mods done it, not sure what kind. Two of the preamp tubes were not lighting up. I checked to see if the tubes were bad by switching them around and found out that a 12ax7 in place of where the 12at7 should be makes all of the preamp tubes light up. Weird. I plugged it up to my cab, let it warm up, then flipped the standby switch and then ZZZZZZZZZZZZZ. I could actually see light coming from the inputs. Fuse blew. Unplugged it and looked in the back. One of the power tube sockets had been burn slightly along with the base of the tube. Can anyone explain what might be going on with this thing?

muchxs
May 24th, 2010, 04:33 PM
Can anyone explain what might be going on with this thing?

Yeah. As I usually put it, "It's been messed with." No telling how or by whom without looking at it. I hope you got a really good deal on it because it's probably tech time. Your obvious options would be to have it put back to stock by someone who knows what they're doing or the more difficult path, have someone try to interpret the intent of the previous owner and the guy who messed with it then make it work properly. Mods aren't a bad thing if the tech who performs them is well versed in the various possibilities and is able to execute said mods with a reasonable level of craftsmanship.

Burnt parts, small lightning storms and blown fuses are never a good thing.

mercymercyme03
May 24th, 2010, 10:51 PM
Thanks for the input. I looked inside and it's terrible. Whoever tried to mod it did a sloppy job. It's quite overwhelming. To the tech it goes...