Roland JC 120... can it save the show? - Telecaster Guitar Forum
The Number 1 Fender Telecaster Guitar authority in the world.
   

Go Back   Telecaster Guitar Forum > Amplifier Discussion Forums > Amp Central Station
Forgot Username/Password? Join Us!

Amp Central Station Amps, tubes, speakers & everything AMP related.


Wilde Pickups by Bill & Becky Lawrence WD Music Products Amplified Parts Mod Kits DIY Amps, Mods, Pedals Nordstarnd Pickups Warmoth.com seymourduncan.com


Forum Jump


Reply
 
Thread Tools
Old November 4th, 2006, 12:27 PM   #1 (permalink)
Tele-Meister
 
G-Yo's Avatar
 
Join Date: Sep 2006
Location: Pensacola, FL
Age: 38
Posts: 217
Roland JC 120... can it save the show?

So, I blew a channel in my amp (Carvin xv112 with 4 EL34 tubes, 3 12ax7 preamp tubes) during a rehearsal last night. It was the dirty channel that died, which I use for a little tone coloration, but I'm concerned that the amp needs to be looked over before I play it live somewhere. Even through the clean channel, I'm getting some intermittent crackly fizzley sounds, especially at louder volumes with the bassier notes. Maybe it needs a cap job or more, I'm not that technically oriented.

The problem is, we have a show tonight. So, here are my options:

1 - Play through the Carvin, just use the clean channel and hope it doesn't fry on stage.

2 - Play my other amp, which is a '75 Peavey Deuce II (6L6 power, solid state pre). It has a bit of a hum, and I'm not as happy with the tone. To much mid, not enough low end. It's decent, just not as good as the Carvin.

3 - Or... I can rent a Roland JC 120 from the local music store for $35. Now, I've heard that these amps have great clean tone and take pedals well. I use pedals for my effects (od, dist and reverb), but I always like the tone when the tubes are cranked on the Carvin. Anyone have any experience? Would that be too sqeaky clean in comparison to what I normally use?

I know this is a very subjective and picky question, I just thought someone may have some advice on the Roland JC 120.

Thanks!

G-Yo is offline   Reply With Quote

Old November 4th, 2006, 12:50 PM   #2 (permalink)
Poster Extraordinaire
 
Durtdog's Avatar
 
Join Date: May 2004
Location: Tennessee
Posts: 7,073
It is subjective, so take my opinion for what it's worth.

JC120 is one of my least favorite amps on earth. Sterile ss sound, no guts or singing tones, just hi-fi.

Good luck, lots of people do like them, I just don't happen to be one of them.
__________________
Where did all these chipmunks come from?
Durtdog is offline   Reply With Quote

Old November 4th, 2006, 01:03 PM   #3 (permalink)
Friend of Leo's
 
refin's Avatar
 
Join Date: Feb 2005
Location: Florida Panhandle
Age: 58
Posts: 4,322
Some people (like Adrian Belew) have used the JC-120 as a pedal eater,as they do take effects pretty well.They are sterile and lifeless (to me) as a stand alone amp.Can't beat that chorus though!!
__________________
http://www.soundclick.com/bands/0/refin_music.htm

MASTER VOLUME? WHAT'S A MASTER VOLUME?
refin is offline   Reply With Quote

Sponsored Links   #
Sponsored posting
 

Old November 4th, 2006, 01:24 PM   #4 (permalink)
Tele-Meister
 
G-Yo's Avatar
 
Join Date: Sep 2006
Location: Pensacola, FL
Age: 38
Posts: 217
Thanks guys. That's kinda what I was thinking... I'm leaning towards just taking the Peavey.
G-Yo is offline   Reply With Quote

Old November 4th, 2006, 01:28 PM   #5 (permalink)
Doctor of Teleocity
 
woodman's Avatar
 
Join Date: Nov 2004
Location: Mint Hill, NC
Age: 68
Posts: 13,906
one thing you might try is getting some electronics cleaner from Radio Shack, pull all your tubes and clean the contacts. i've seen this work miracles. tap gently on all your tubes while running to see if you hear anything bad. if any of 'em crackle or pop, replace 'em and see if that does the trick.

if nothing changes after that, i'd take both the Carvin and the Deuce to the gig and see how it shakes out. if the Carvin craps out, you've got a backup you're familiar with. me, i wouldn't pay $5 to use that Roland for a night, but that's just a matter of personal taste.
__________________
Truth is stranger than fact ...
It pays to appease all the gods Gnossos Pappadopoulis

YouTube channel Originals
woodman is offline   Reply With Quote

Old November 6th, 2006, 04:53 PM   #6 (permalink)
Tele-Meister
 
G-Yo's Avatar
 
Join Date: Sep 2006
Location: Pensacola, FL
Age: 38
Posts: 217
Thanks guys - I trust your opinions regarding the JC 120 more than I trust harmony central.com. I took the Deuce to the show, and it did fine.

Woodman, I'll definitely take your advice on the tube maintanance/replacement. Maybe I'll get lucky and that will do the trick. I'll let you know what happens.

Thanks again!
G-Yo is offline   Reply With Quote

Old November 12th, 2006, 11:39 PM   #7 (permalink)
Tele-Meister
 
G-Yo's Avatar
 
Join Date: Sep 2006
Location: Pensacola, FL
Age: 38
Posts: 217
Quote:
Originally Posted by woodman1
one thing you might try is getting some electronics cleaner from Radio Shack, pull all your tubes and clean the contacts. i've seen this work miracles. tap gently on all your tubes while running to see if you hear anything bad. if any of 'em crackle or pop, replace 'em and see if that does the trick.
Okay, so... I pulled the tubes and cleaned the contacts with the electronics cleaner. Upon firing the amp back up, low and behold my OD channel came back to life. Yes! Now that I think of it, when I pulled one of the preamp tubes, it didn't feel like it was inserted all the way. Could have been part of the problem.

However, that crackly sound is still present when I play bassier notes, both on the clean and OD channels. I gently tapped on all of the tubes while running, and that didn't effect the sound. However, when I push gently on the bottom of the preamp tubes (12ax7s), the crackling will stop or reduce. It's almost like I'm keeping something from rattling...but it's definitely a crackle coming from the speaker, not a physical rattle. It doesn't matter which of the 3 preamp tubes I touch, the crackling is reduced.

So, I'm guessing that either the preamp tubes need replacing or something in the preamp circuit needs attention. Any insight?

Thanks again for the help!
G-Yo is offline   Reply With Quote

Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


» Random Photo for Guests
day of the dead tele
Untitled Document



 


Powered by vBadvanced CMPS v3.2.2



IMPORTANT:Treat everyone here with respect, no matter how difficult! No sex, drug, political, religion or hate discussion permitted here.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 RC 2
© TDPRI.COM 1999 - 2014 All rights reserved.